Wampserver 3.1.7 does not showing all warnings, how to force to show?

I am using wampserver 3.1.7 and in php.ini Error_reporting set to --> E_all
but the problem is I am not getting errors or warnings like " Warning : session_start(): Cannot send session cache limiter - headers already sent"

in my localhost (wampserver) but on realserver (online) it is showing. No mater with the PHP version set, tried to 5.6 to 7.3!

other problem is for the warning “session_start(): Cannot send session cache limiter - headers already sent” when as per solution I found on net no line should be before <?PHP in page. I also wrote as said but this warning is still showing. What other could it be?

Than you for spending some time to help me.

The actual setting value is E_ALL (all capital letters.) What does a php script with a phpinfo() statement in it show for the following settings -

The error message should state WHERE the output is occurring at - file name and line number (there were some php versions where they messed this up and didn’t show where the output was occurring at, you should always use the latest php version.) . If the line number is 1, and you have removed any actual character(s) before the 1st opening php tag, the problem is usually because your file has been saved with the Byte Order Mark BOM characters. You need to configure your programming editor to save files without the BOM characters.

Thank you for your quick response. I willl check it out and let you know the updates. and “value is E_ALL (all capital letters.)” is in all caps - I posted the smalls here. Have a great day sir.

Sponsor our Newsletter | Privacy Policy | Terms of Service