Timeouts When Uploading Attachments


I am on a dedicated server and this is the last thing I need to ‘get right’ before I release my site to the public and it’s the most important so any help is much appreciated!

Before I moved to CloudFlare, I tested a file of 211MB in size as an upload and it worked and worked fast. After I moved, it times out almost exactly 30 seconds from when I click the submit button.

I tried messing with php.ini settings and apache settings but they both don’t seem to have any effect, I keep getting the same timeouts.

What can I do?


Hi there.

To check if your changes to php.ini take effect create a php script with this line:
[php]<?php echo phpinfo(); ?>[/php]

Then, try to change these settings in php.ini (and check if phpinfo shows these changes):

max_execution_time = 1200 memory_limit = 128M upload_max_filesize = 64M post_max_size = 64M

You can also do this in .htaccess (for example, per directory):

php_value max_execution_time 1200 php_value memory_limit 128M php_value upload_max_filesize 64M php_value post_max_size 64M


Yes, the changes are in effect. This problem seems to be with the Cloud Flare servers and there isn’t anything I can do about it.

Thanks for the help though

Sponsor our Newsletter | Privacy Policy | Terms of Service