PHP not redirecting to next page (IIS7)

#1

I have installed PHP 5.4 with IIS7. I also have MySQL5.5 installed. Running localhost I can open the initial PHP page which is a login page to my website but when I click on a button on that page that should transfer me to the next page all I get is a blank screen.
I initially developed these pages on a different PC under Apache and everything works fine.
I started from scratch installing PHP on the box with IIS. Then I just transferred my previously developed pages to the root directory. I am assuming that the php code should not change.
I think I must be missing something critical in the php.ini file but I don’t know what that is.
Several installation instructions from the web all seem to be slightly different.
Any suggestions?

#2

I’m running IIS 7.

Go into your PHP manager and go into error reporting and open the log. I’m taking it you have it set as a production machine, this means errors are not shown on the page but rather in the log. If you have any trouble troubleshooting via the log, get back and I’ll take a look.

#3

Thanks.
Let me state that I am not well versed in the “under the covers” setup that needs to be done. I am primarily an applications person.
I have found the logs for IIS but I do not see php manager.
I am starting to think that I may need to reinstall PHP.
Like I said initially I have found several links for install instructions on the web and each one has some slightly different information. This site
http://blog.pluralsight.com/iis-7-install-fastcgi-php (first does this look like a good set of instructions?)
does not mention copying the php.ini file to the windows folder like other instructions say to. Just leave it in the PHP folder. Does it make a difference? Right now the .ini in the windows folder and the .ini in the php folder are different.
Also I may not have selected IIS FastCGI like it suggests, although I did do some fastcgi settings through the IIS manager.
The primary changes to php.ini appear to be:
fastcgi.impersonate = 1
cgi.fix_pathinfo = 1
cgi.force_redirect = 0

I have also seen these:
open_basedir = c:\inetpub
fastcgi.logging = 0
doc_root = “C:\inetpub\wwwroot”
extension_dir = :C:\php\ext"
extensions = php_mbstring.dll
extensions=php_gd2.dll
extensions=php_mysqli.dll
extensions=php_mysql.dll
session.save_path=“C:\php\session”
I don’t know which of these are required and which are not.

Then recently I learned something else about where I am installing on IIS.
There is another website already setup under IIS running asp.net. I know that these cannot run at the same time through the same port. So I am sure that complicates things.
Can both of these even be running on the same server? or am I fighting a losing battle?

Like I said I am not a systems guy so any help is appreciated.

#4

I use IIS7 also…

I bet your php code is using Short tags…

Add this to you php.ini

short_open_tag = 1

#5

Thus I guess the PHP programmers will have to change their code, running with PHP 5.5.x.


aliiii