php install headache


#1

Hey trying to update my php from 4.2 to 4.3 and this is turning into a complete headache. I have tried installing some RPM’s from http://us.seekbrain.com/downloads/psa/9/RPMS/ and im getting errors
error: Failed dependencies:
libaspell.so.15 is needed by php-4.3.7-sp.rh9.1
libpspell.so.15 is needed by php-4.3.7-sp.rh9.1
php = 4.2.2-17 is needed by (installed) php-imap-4.2.2-17
php = 4.2.2-17 is needed by (installed) php-ldap-4.2.2-17
php = 4.2.2-17 is needed by (installed) php-mysql-4.2.2-17
php = 4.2.2-17 is needed by (installed) php-odbc-4.2.2-17
So i then tried to install it just like it says from the php.net doc’s. Nope that didnt work either
Can someone instruct me or point me into a direction of getting this installed without pulling out my hair. Thanks

Redhat 9


#2

Try uninstalling everything related to PHP before starting the installation. An other solution would be to upgrade the system to Fedora.

I usually install PHP from source. On a RPM-based system, you will probably need to instal a few -devel packages in order to have the required libraries and header files.


#3

Thats what i did… fedora core… Working great now!!