Nuts Nuts


#1

Hi my friends,

I got so :roll: that I really lost,

I just send up a root server box from 1and1, and when I try
test.html

<? echo "helloworldID=$id"; ?>

my code can’t grap the id value from query string! it just print “helloworldID=”

any clues?

here is my phpinfo

Linux stripples.devel.redhat.com 2.4.21-1.1931.2.274.entsmp #1 SMP Tue Jun 24 11:18:10 EDT 2003 i686 i686 i386 GNU/Linux
Build Date Jun 29 2003 16:34:10
Configure Command ‘./configure’ ‘–host=i386-redhat-linux’ ‘–build=i386-redhat-linux’ ‘–target=i386-redhat-linux-gnu’ ‘–program-prefix=’ ‘–prefix=/usr’ ‘–exec-prefix=/usr’ ‘–bindir=/usr/bin’ ‘–sbindir=/usr/sbin’ ‘–sysconfdir=/etc’ ‘–datadir=/usr/share’ ‘–includedir=/usr/include’ ‘–libdir=/usr/lib’ ‘–libexecdir=/usr/libexec’ ‘–localstatedir=/var’ ‘–sharedstatedir=/usr/com’ ‘–mandir=/usr/share/man’ ‘–infodir=/usr/share/info’ ‘–cache-file=…/config.cache’ ‘–with-config-file-path=/etc’ ‘–with-config-file-scan-dir=/etc/php.d’ ‘–enable-force-cgi-redirect’ ‘–disable-debug’ ‘–enable-pic’ ‘–disable-rpath’ ‘–enable-inline-optimization’ ‘–with-bz2’ ‘–with-db3’ ‘–with-curl’ ‘–with-dom=/usr’ ‘–with-exec-dir=/usr/bin’ ‘–with-freetype-dir=/usr’ ‘–with-png-dir=/usr’ ‘–with-gd’ ‘–enable-gd-native-ttf’ ‘–with-ttf’ ‘–with-gdbm’ ‘–with-gettext’ ‘–with-ncurses’ ‘–with-gmp’ ‘–with-iconv’ ‘–with-jpeg-dir=/usr’ ‘–with-openssl’ ‘–with-png’ ‘–with-pspell’ ‘–with-regex=system’ ‘–with-xml’ ‘–with-expat-dir=/usr’ ‘–with-zlib’ ‘–with-layout=GNU’ ‘–enable-bcmath’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-magic-quotes’ ‘–enable-safe-mode’ ‘–enable-sockets’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-discard-path’ ‘–enable-track-vars’ ‘–enable-trans-sid’ ‘–enable-yp’ ‘–enable-wddx’ ‘–without-oci8’ ‘–with-pear=/usr/share/pear’ ‘–with-imap=shared’ ‘–with-imap-ssl’ ‘–with-kerberos=/usr/kerberos’ ‘–with-ldap=shared’ ‘–with-mysql=shared,/usr’ ‘–with-pgsql=shared’ ‘–with-snmp=shared,/usr’ ‘–with-snmp=shared’ ‘–enable-ucd-snmp-hack’ ‘–with-unixODBC=shared’ ‘–enable-memory-limit’ ‘–enable-bcmath’ ‘–enable-shmop’ ‘–enable-versioning’ ‘–enable-calendar’ ‘–enable-dbx’ ‘–enable-dio’ ‘–enable-mcal’ ‘–with-apxs2=/usr/sbin/apxs’
Server API Apache 2.0 Filter
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php.ini
Scan this dir for additional .ini files /etc/php.d
additional .ini files parsed /etc/php.d/imap.ini,
/etc/php.d/mysql.ini

Debug Build no
Thread Safety disabled

This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.2.0, Copyright © 1998-2002 Zend Technologies


#2

Try using $_GET[“id”] instead of $id, I didn’t bother to look through your phpinfo but your register globals (or are they autoglobals? whatever) are probably turned off.


#3

Hi Da,

that works! now I read through the phpinfo and the only one with global is
“register_globals” and it is off, how I can turn it on? do you have some clues? can you show me some pages which have this? thanks a lot.


#4

Turning on your register globals is generally considered a large security hole. But if you insist go to your php.ini file and look for register_globals = Off and erase off and type on.