Desperation setting in over magic quotes


#1

Hi guys.
I am attempting to get Commentic to function for me. My biggest hurdle is switching off magic quotes, and I am at the point of throwing the towel in over it.
First of all I am hosted by Godaddy, on a Linux server, who have been a treasure to me in the past, but cannot or will not help me with this problem.
I searched for an answer and eventually created and uploaded a php5.ini file into the root folder of my site, which is an alias to the primary domain.
Here is the contents of the file:

magic_quotes_gpc = Off; magic_quotes_runtime = Off; magic_quotes_sybase = Off;

Checking by uploading a phpinfo.php file to the primary domain root folder I get:

magic quotes gpc On
magic quotes runtime Off
magic quotes sybase Off

This is born out by the malfunction of my comments page when I attempt to add a video or an image to the comment, I can’t.
My problem is that whilst searching for an answer, I came accross the notion that a php(5).ini file was “quite a large file”, certainly more than my three lines. Yet the file that accompanied this instruction was dedicated to another application so I decided not to copy it and add my three lines to it. So I am not sure what a php5.ini file should look like, I may have the file written correct, if so why won’t it work and disable magic quotes? I also saw that I was supposed to put the file in every directory with php in it, so I did that, nothing.
I have ended the processes, not as there were any, still nothing.
I am staggered that I can’t get this resolved, I have searched anywhere and everywhere but nothing has worked.
Help with this would be wonderful.
Henri. :o


#2

have you tired using htaccess?

create a text file name is .htaccess in the root of your site and put in it:

php_value magic_quotes 0
php_flag magic_quotes off
php_value magic_quotes_gpc 0
php_flag magic_quotes_gpc off

#3

Thanks.
Yes I had done that, although I am getting confused as to whether I should be putting these files in the primary domain. So I tried it again in to my aliased site(not the primary) and still nothing.
I have tried so many things now. Even the guy that wrote Commentic can’t tell me what to do. I don’t know if it is a Godaddy problem even?