Compiling PHP 5.6.4 on Ubuntu 12.04 with odd error message

#1

Hi guys,

for days now I have been trying to compile PHP 5.6.4 as FastCGI on a VPS with Ubuntu 12.04 (32bit) and I am stuck with a very odd error message which I don’t understand and Google wasn’t very helpful either (unlike with all the other errors I encountered) :slight_smile:

So I hope I can get some more information from you guys.

The premises:

I’ve got an Ubuntu 12.04 32bit VPS with an old 5.3 PHP, however some forums and boards need a more up-to-date PHP version. As Plesk is running on that server, I cannot update PHP and have to run an additional PHP as FastCGI.

I managed to get it to work on my first VPS which is a CentOS 6.6 64bit server. But this Ubuntu-VPS is really killing me.

On CentOS i followed these steps provided by Parallel themselves:
http://kb.sp.parallels.com/en/118378

Now I have to tell you that I basically know nothing about Linux and am far away of being even considered a beginner. However this kb worked out like charm.

With Ubuntu this however is getting more and more complicated. I got the source from PHP.net directly, installed it on my virtual machine and ./configure’ed and make’ed it. This was complicated enough, but I got it to work without any problems eventually.

I then send this package to my VPS and unpacked it and said make install. And that’s where I stuck with this fancy error message which I cannot decipher at all and I hope you can help me with that:

[code]xxxx@xxxxx:/usr/local/src/php564# make install
Generating phar.phar

Warning: Creating default object from empty value in /usr/local/src/php564/ext/phar/phar.php on line 165

Catchable fatal error: Argument 1 passed to CLICommand::getCommands() must be an instance of CLICommand, instance of stdClass given, called in /usr/local/src/php564/ext/phar/phar.php on line 167 and defined in /usr/local/src/php564/ext/phar/phar.php on line 274
make: *** [ext/phar/phar.phar] Error 255
xxxx@xxxxx:/usr/local/src/php564#[/code]

As said, I had no issue whatsoever with my CentOS VPS and Parallels guide is simple enough to follow it through. I managed to figure out when packages were missing that they had to be installed - Google helped me with that a lot. :slight_smile:

But this message is just gibberish and google wouldn’t find any message that would help me deciphering what it meant. Obviously phar is installed, the folder exists, files are in there.

Any ideas?

Thank you,

Philippe

#2

You don’t need to compile php yourself, just update it :slight_smile:

sudo apt-get install software-properties-common sudo add-apt-repository ppa:ondrej/php5-5.6 sudo apt-get update sudo apt-get upgrade sudo apt-get install php5

#3

As I said… I can’t update it. Plesk is relying on 5.3.10, the only alternative is FastCGI.

If it were that simple, I would have done that already. I know how to update things that way. But on our VPS with Pleks this is unfortunately not possible… for me anyway. :slight_smile:

#4

Oh, and as mentioned in my first post… it’s Ubuntu 12.04, not 14.04!

#5

Multiple PHP versions and Plesk

Plesk Release Notes

#6

Hi, as you can see in my original post, that is exactly what I am trying to do. My problem starts at step d) of your posted link which I posted in my original post already.

Maybe I should clarify something first:
I am well aware of how to do simple tasks like this and I pointed out in my original post, that I have already performed this on other systems like CentOS 6 and I had no problem with exactly these instructions.

As I said, I have been sitting on this very particular problem for the last two days and I have found many… many links on solving issues but not this particular, very strange and cryptic error message and I hoped you guys would be able to help me. I tried googling for the error message I got but I basically only find 1-2 google result pages and none of them describe my problem and most of them are in an asian language I don’t speak. :slight_smile:

To avoid further suggestions of this kind:

  • I cannot change the OS
  • I cannot change Plesk
  • I cannot change the fact that Plesk only lets me install PHP 5.3.10
  • Therefore I have to use newer PHP versions via FastCGI
  • For that I have to compile a newer PHP version on Ubuntu 12.04 from scratch – with FastCGI
  • The same procedure worked on other OS+Plesk, just not on this Ubuntu

And finally:
I don’t find anything that explains what the error message means and where I can find a solution for this.
A pointer towards the right direction or some instructions referring to that problem would be very much appreciated. :slight_smile:

If there’s anything unclear about my problem, please let me know and I’ll try to explain as much as I can.

#7

I’m not understanding why you can’t upgrade Plesk. I personally don’t even like Plesk, but that isn’t the point.

Have you seen this article?

#8

Because it’s a VPS from a hosting provider - so I am limited to what I’ve got and what Plesk 12 is telling me is available for the OS I am being provided with.

And unfortunately I am no guru who can setup these things without plesk’s help. I have to rely on tools like this. :slight_smile:

Yes I had a look at that and that’s basically a more sophisticated version of what I am doing, but it still doesn’t explain the problem I’ve got. First time I saw this article I also tried to install the same packages as mentioned there, just in case I forgot to install one. It made no difference.

Private Virtual Server where I compiled my FastCGI PHP version:
./configure --> worked fine
make --> worked fine

Moving to the hosting provider’s machine:
make install --> fails with cryptic error message described in my first post.

I figured as much as I don’t have to install anything. It seems to be rather an error in commands created in the script file, if I understand correctly.

The testing and the production server have the same version (just double-checked) Ubuntu 12.04.5 LTS.

#9

Then it may come down to your particular host, unfortunately. Some hosting companies view VPS’s as dedicated, do what you want machines. You are not limited to what they provide, because it is your machine.

Others, place limits on partitioning it out and keep tight control of the system least you fuck it up.

My honest view, I don’t know whom your host is… Contact them and see if their tech support can look into it.

#10

Either way, how much time is this worth? It costs from $5/month to spin up a VPS where you could have the latest ubuntu/php version. If you have spent just a few hours on this then that is a lot more.

#11

Thanks, was worth a try.