CGI timeout error


#1

Hello,

I installed php 5.0 and am using IIS (v5.1) as a web server.
The problem is web browser always just complains
“CGI time out” message after some time instead of showing the php page properly.
I did following:
Under ‘Home Directory’, ‘Virtual Directory’, or ‘Directory’, click on the ‘Configuration’ button, and then enter the App Mappings tab.

Click Add, and in the Executable box, type: c:phpphp.exe (assuming that you have unziped PHP in c:php).

In the Extension box, type the file name extension you want associated with PHP scripts. Leave ‘Method exclusions’ blank, and check the Script engine checkbox. You may also like to check the ‘check that file exists’ box - for a small performance penalty, IIS (or PWS) will check that the script file exists and sort out authentication before firing up php. This means that you will get sensible 404 style error messages instead of cgi errors complaining that PHP did not output any data.

Please help me to sovle this problem.
Thank you.