Author Topic: SMTP server response 530 5.7.3  (Read 1708 times)

rmorf

  • Just Joined
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
SMTP server response 530 5.7.3
« on: May 08, 2007, 03:52:47 am »
Hi
I am new to PHP and i had to transfer a php page to a windows server. I setup evrything and the page in general is working fine but i have the following problem with a send mail function.

It gives me the following error:

Warning: mail() [function.mail]: SMTP server response: 530 5.7.3 Client was not authenticated in C:InetpubwwwrootLocalUserftphhbrascalsrascalsdoregister.php on line 81

and line 81 is : mail($emailaddress,"New Registration",$etext,$headers);
and here is the full code:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   <?
  
	
$emailaddress "mail@server.com";
  
  
	
$name $HTTP_GET_VARS['name'];
	

  
	
$dob $HTTP_GET_VARS['dob'];
	

  
	
$email $HTTP_GET_VARS['email'];
	

  
	
$eyecolour $HTTP_GET_VARS['eyecolour'];
	

  
	
$haircolour $HTTP_GET_VARS['haircolour'];
	

  
	
$height $HTTP_GET_VARS['height'];
	

 
	
$shoesize $HTTP_GET_VARS['shoesize'];
	

 
	
$height $HTTP_GET_VARS['height'];
	

 
	
$uploadimage $HTTP_GET_VARS['image1'];
	

 
 
	
$etext "<html><head></head><body>" 
 
	
"Name:$name<br>" .
 
	
"DOB:$dob<br>" .
 
	
"Email:$email<br>" .
 
	
"Eyecolour:$eyecolour<br>" .
 
	
"Haircolour:$haircolour<br>" .
 
	
"Height:$height<br>" .
 
	
"Shoesize:$shoesize<br>" .
 
	
"Height:$height<br>";
 
 
 
	
$headers 'From: <!-- e -->mail@server.com<!-- e -->' "rn" .
 
	
	
'X-Mailer: PHP/' phpversion();
 
	
	
	

 
	
mail($emailaddress,"New Registration",$etext,$headers);
         
 
?>




Please help me.

Thanks inadvance

Mod Edit: Added PHP tags and obfuscated email address

PHP Help Forum

SMTP server response 530 5.7.3
« on: May 08, 2007, 03:52:47 am »


Zyppora

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 1401
  • Karma: 0
    • View Profile
(No subject)
« Reply #1 on: May 08, 2007, 06:19:42 am »
Sounds like a permission problem. What did you find when searching the internet for the warning message? Is the windows server hosted, or is it your own machine? If hosted, have you contacted your host concerning this problem?
HAVE YOU TRIED DEBUGGING? Example code in this reply deliberately contains BUGS. PHP forum for beginners.

rmorf

  • Just Joined
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
(No subject)
« Reply #2 on: May 08, 2007, 06:30:45 am »
Its my own machine and we use mostly asp but we are sending emails fine. So i dont think that the problem is the setup os the smtp